# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"format\((.*), (.*), \"(.*)\", (.*)+\)"
test_str = ("mformat(ee_stri, sizeof(ee_stri), \" %s (%d) po raz %d wygrał {b}/ws{/b}. I otrzymuje {b}%d Score i %d${/b} \", playerNick(script_ws[ winreed ]), script_ws[ winreed ], addPointEvent(script_ws[ winreed], stats_ws), score, kasy); \n\n\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.