// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Z][a-z]+([ ][A-Z][a-z]*)*$
").unwrap();
let string = "Le Thanh Toan
Nuyen Thanh Toan
Le Nguyen Thanh Toan
Le Tran Nguyen Bui Huynh Thanh Toan
Le Toan
Le T
Toan
nguyen
nguyen nam
nguyen long
nguyen Thanh
Nguyen thanh
Le Toan
NguyeN NaM LonG";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}