#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z][a-z]+([ ][A-Z][a-z]*)*$" & @CRLF & _
""
Local $sString = "Le Thanh Toan" & @CRLF & _
"Nuyen Thanh Toan" & @CRLF & _
"Le Nguyen Thanh Toan" & @CRLF & _
"Le Tran Nguyen Bui Huynh Thanh Toan" & @CRLF & _
"Le Toan" & @CRLF & _
"Le T" & @CRLF & _
"Toan" & @CRLF & _
"" & @CRLF & _
"nguyen" & @CRLF & _
"nguyen nam" & @CRLF & _
"nguyen long " & @CRLF & _
"nguyen Thanh" & @CRLF & _
"Nguyen thanh" & @CRLF & _
"Le Toan " & @CRLF & _
"NguyeN NaM LonG"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")