package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z][a-z]+([ ][A-Z][a-z]*)*$
`)
var str = `Le Thanh Toan
Nuyen Thanh Toan
Le Nguyen Thanh Toan
Le Tran Nguyen Bui Huynh Thanh Toan
Le Toan
Le T
Toan
nguyen
nguyen nam
nguyen long
nguyen Thanh
Nguyen thanh
Le Toan
NguyeN NaM LonG`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}