const regex = /^[A-Z][a-z]+([ ][A-Z][a-z]*)*$
/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z][a-z]+([ ][A-Z][a-z]*)*$
', 'gm')
const str = `Le Thanh Toan
Nuyen Thanh Toan
Le Nguyen Thanh Toan
Le Tran Nguyen Bui Huynh Thanh Toan
Le Toan
Le T
Toan
nguyen
nguyen nam
nguyen long
nguyen Thanh
Nguyen thanh
Le Toan
NguyeN NaM LonG`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}