import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z][a-z]+([ ][A-Z][a-z]*)*$\n";
final String string = "Le Thanh Toan\n"
+ "Nuyen Thanh Toan\n"
+ "Le Nguyen Thanh Toan\n"
+ "Le Tran Nguyen Bui Huynh Thanh Toan\n"
+ "Le Toan\n"
+ "Le T\n"
+ "Toan\n\n"
+ "nguyen\n"
+ "nguyen nam\n"
+ "nguyen long \n"
+ "nguyen Thanh\n"
+ "Nguyen thanh\n"
+ "Le Toan \n"
+ "NguyeN NaM LonG";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}