re = /^[A-Z][a-z]+([ ][A-Z][a-z]*)*$
/m
str = 'Le Thanh Toan
Nuyen Thanh Toan
Le Nguyen Thanh Toan
Le Tran Nguyen Bui Huynh Thanh Toan
Le Toan
Le T
Toan
nguyen
nguyen nam
nguyen long
nguyen Thanh
Nguyen thanh
Le Toan
NguyeN NaM LonG'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end