import Foundation
let pattern = #"<img.+src=[\'"](?P<src>.+?)[\'"].*>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"""
<table><tr><td><img src='http://newstarget.com/wp-content/uploads/sites/43/2016/10/hillary9-168x95.jpg' width='168' height='95' /></td><td valign='top'>
Many of us have been wondering exactly how Hillary Clinton has been able to get away with her blatant, obvious corruption for so long now. Even though it’s well known that the federal government protects their own and the Democrats will go above and beyond to avoid condemning a member of their party, Hillary has […] </td></tr></table>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}