import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img.+src=[\\'\"](?P<src>.+?)[\\'\"].*>";
final String string = "<table><tr><td><img src='http://newstarget.com/wp-content/uploads/sites/43/2016/10/hillary9-168x95.jpg' width='168' height='95' /></td><td valign='top'>\n"
+ " Many of us have been wondering exactly how Hillary Clinton has been able to get away with her blatant, obvious corruption for so long now. Even though it’s well known that the federal government protects their own and the Democrats will go above and beyond to avoid condemning a member of their party, Hillary has […] </td></tr></table>\n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}