use strict;
my $str = '<table><tr><td><img src=\'http://newstarget.com/wp-content/uploads/sites/43/2016/10/hillary9-168x95.jpg\' width=\'168\' height=\'95\' /></td><td valign=\'top\'>
Many of us have been wondering exactly how Hillary Clinton has been able to get away with her blatant, obvious corruption for so long now. Even though it’s well known that the federal government protects their own and the Democrats will go above and beyond to avoid condemning a member of their party, Hillary has […] </td></tr></table>
';
my $regex = qr/<img.+src=[\'"](?P<src>.+?)[\'"].*>/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}