$re = '/<img.+src=[\'"](?P<src>.+?)[\'"].*>/i';
$str = '<table><tr><td><img src=\'http://newstarget.com/wp-content/uploads/sites/43/2016/10/hillary9-168x95.jpg\' width=\'168\' height=\'95\' /></td><td valign=\'top\'>
Many of us have been wondering exactly how Hillary Clinton has been able to get away with her blatant, obvious corruption for so long now. Even though it’s well known that the federal government protects their own and the Democrats will go above and beyond to avoid condemning a member of their party, Hillary has […] </td></tr></table>
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);