// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((\+88)?(01)[0-9]{9}|[1-9][0-9]{6})$").unwrap();
let string = "+8801679453663
7273591
01679453663
+8801984442842
2373453
1012588";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}