using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((\+88)?(01)[0-9]{9}|[1-9][0-9]{6})$";
string input = @"+8801679453663
7273591
01679453663
+8801984442842
2373453
1012588";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}