import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((\\+88)?(01)[0-9]{9}|[1-9][0-9]{6})$";
final String string = "+8801679453663\n"
+ "7273591\n"
+ "01679453663\n"
+ "+8801984442842\n"
+ "2373453\n"
+ "1012588";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}