package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((\+88)?(01)[0-9]{9}|[1-9][0-9]{6})$`)
var str = `+8801679453663
7273591
01679453663
+8801984442842
2373453
1012588`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}