$re = '/^((\+88)?(01)[0-9]{9}|[1-9][0-9]{6})$/m';
$str = '+8801679453663
7273591
01679453663
+8801984442842
2373453
1012588';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);