#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((\+88)?(01)[0-9]{9}|[1-9][0-9]{6})$"
Local $sString = "+8801679453663" & @CRLF & _
"7273591" & @CRLF & _
"01679453663" & @CRLF & _
"+8801984442842" & @CRLF & _
"2373453" & @CRLF & _
"1012588"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")