// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(-\d+|\d+,?)*\.\d+(e\d+)?|\d+$").unwrap();
let string = "3.14529
-255.34
128
1.9e10
123,340.00
720p";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}