$re = '/^(-\d+|\d+,?)*\.\d+(e\d+)?|\d+$/m';
$str = '3.14529
-255.34
128
1.9e10
123,340.00
720p';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);