const regex = new RegExp('^(-\\d+|\\d+,?)*\\.\\d+(e\\d+)?|\\d+$', 'gm')
const str = `3.14529
-255.34
128
1.9e10
123,340.00
720p`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}