#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(-\d+|\d+,?)*\.\d+(e\d+)?|\d+$"
Local $sString = "3.14529" & @CRLF & _
"-255.34" & @CRLF & _
"128" & @CRLF & _
"1.9e10" & @CRLF & _
"123,340.00" & @CRLF & _
"720p"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")