package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(-\d+|\d+,?)*\.\d+(e\d+)?|\d+$`)
var str = `3.14529
-255.34
128
1.9e10
123,340.00
720p`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}