using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(-\d+|\d+,?)*\.\d+(e\d+)?|\d+$";
string input = @"3.14529
-255.34
128
1.9e10
123,340.00
720p";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}