import Foundation
let pattern = #"<img.*?src\s*=\s*("|')(?P<source>.*?)\1.*?>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<img src="/images/stories/News/NEWS_11_01_13_2.jpg" alt="NEWS 11_01_13_2" width="100" height="67" style="margin: 0px; padding: 0px; float: none; border: none;">"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}