const regex = /<img.*?src\s*=\s*("|')(?P<source>.*?)\1.*?>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img.*?src\\s*=\\s*("|\')(?P<source>.*?)\\1.*?>', '')
const str = `<img src="/images/stories/News/NEWS_11_01_13_2.jpg" alt="NEWS 11_01_13_2" width="100" height="67" style="margin: 0px; padding: 0px; float: none; border: none;">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}