use strict;
my $str = '<img src="/images/stories/News/NEWS_11_01_13_2.jpg" alt="NEWS 11_01_13_2" width="100" height="67" style="margin: 0px; padding: 0px; float: none; border: none;">';
my $regex = qr/<img.*?src\s*=\s*("|')(?P<source>.*?)\1.*?>/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}