import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img.*?src\\s*=\\s*(\"|')(?P<source>.*?)\\1.*?>";
final String string = "<img src=\"/images/stories/News/NEWS_11_01_13_2.jpg\" alt=\"NEWS 11_01_13_2\" width=\"100\" height=\"67\" style=\"margin: 0px; padding: 0px; float: none; border: none;\">";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}