// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(pgt_)([\d]*)(_fixed|_percentual)$").unwrap();
let string = "pgt_1_fixed
pgt_10_fixed
sadasfaspgt_10_fixed01293123
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}