using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(pgt_)([\d]*)(_fixed|_percentual)$";
string input = @"pgt_1_fixed
pgt_10_fixed
sadasfaspgt_10_fixed01293123
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}