package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(pgt_)([\d]*)(_fixed|_percentual)$`)
var str = `pgt_1_fixed
pgt_10_fixed
sadasfaspgt_10_fixed01293123
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}