re = /^(pgt_)([\d]*)(_fixed|_percentual)$/
str = 'pgt_1_fixed
pgt_10_fixed
sadasfaspgt_10_fixed01293123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end