$re = '/^(pgt_)([\d]*)(_fixed|_percentual)$/';
$str = 'pgt_1_fixed
pgt_10_fixed
sadasfaspgt_10_fixed01293123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);