const regex = /^(pgt_)([\d]*)(_fixed|_percentual)$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(pgt_)([\\d]*)(_fixed|_percentual)$', 'g')
const str = `pgt_1_fixed
pgt_10_fixed
sadasfaspgt_10_fixed01293123
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}