// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)((http[s]?\:)\/\/)?([^\?\:\/#]+)(\:([0-9]+))?(\/[^\?\#]*)?(\?([^#]*))?(#.*)?").unwrap();
let string = "http://127.0.0.1:8080/some/path?a=1&b=2&a=3#asdflk
www.url-with-querystring.com/?url=has-querystring
http://www.google.com#!something
http://www.google.com?a=1&b=2&a=3
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}