package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)((http[s]?\:)\/\/)?([^\?\:\/#]+)(\:([0-9]+))?(\/[^\?\#]*)?(\?([^#]*))?(#.*)?`)
var str = `http://127.0.0.1:8080/some/path?a=1&b=2&a=3#asdflk
www.url-with-querystring.com/?url=has-querystring
http://www.google.com#!something
http://www.google.com?a=1&b=2&a=3
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}