using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((http[s]?\:)\/\/)?([^\?\:\/#]+)(\:([0-9]+))?(\/[^\?\#]*)?(\?([^#]*))?(#.*)?";
string input = @"http://127.0.0.1:8080/some/path?a=1&b=2&a=3#asdflk
www.url-with-querystring.com/?url=has-querystring
http://www.google.com#!something
http://www.google.com?a=1&b=2&a=3
";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}