const regex = /((http[s]?\:)\/\/)?([^\?\:\/#]+)(\:([0-9]+))?(\/[^\?\#]*)?(\?([^#]*))?(#.*)?/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((http[s]?\\:)\\\/\\\/)?([^\\?\\:\\\/#]+)(\\:([0-9]+))?(\\\/[^\\?\\#]*)?(\\?([^#]*))?(#.*)?', 'i')
const str = `http://127.0.0.1:8080/some/path?a=1&b=2&a=3#asdflk
www.url-with-querystring.com/?url=has-querystring
http://www.google.com#!something
http://www.google.com?a=1&b=2&a=3
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}