$re = '/((http[s]?\:)\/\/)?([^\?\:\/#]+)(\:([0-9]+))?(\/[^\?\#]*)?(\?([^#]*))?(#.*)?/i';
$str = 'http://127.0.0.1:8080/some/path?a=1&b=2&a=3#asdflk
www.url-with-querystring.com/?url=has-querystring
http://www.google.com#!something
http://www.google.com?a=1&b=2&a=3
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);