import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((http[s]?\\:)\\/\\/)?([^\\?\\:\\/#]+)(\\:([0-9]+))?(\\/[^\\?\\#]*)?(\\?([^#]*))?(#.*)?";
final String string = "http://127.0.0.1:8080/some/path?a=1&b=2&a=3#asdflk\n"
+ "www.url-with-querystring.com/?url=has-querystring\n"
+ "http://www.google.com#!something\n"
+ "http://www.google.com?a=1&b=2&a=3\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}