re = /ticky: ([A-Z]*): ([\w ]*) \[([#0-9]*)\] \(([\w]*)\)/m
str = 'May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (username)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end