import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ticky: ([A-Z]*): ([\\w ]*) \\[([#0-9]*)\\] \\(([\\w]*)\\)";
final String string = "May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (username)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}