const regex = new RegExp('ticky: ([A-Z]*): ([\\w ]*) \\[([#0-9]*)\\] \\(([\\w]*)\\)', 'gm')
const str = `May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (username)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}