package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ticky: ([A-Z]*): ([\w ]*) \[([#0-9]*)\] \(([\w]*)\)`)
var str = `May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (username)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}