$re = '/ticky: ([A-Z]*): ([\w ]*) \[([#0-9]*)\] \(([\w]*)\)/m';
$str = 'May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (username)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);