using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ticky: ([A-Z]*): ([\w ]*) \[([#0-9]*)\] \(([\w]*)\)";
string input = @"May 27 11:45:40 ubuntu.local ticky: INFO: Created ticket [#1234] (username)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}