re = /^(.+)\.html(.*)$/
str = 'https://example.com/about.html?pageback=video&jdjahdjahd'
subst = '$1$2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result