const regex = /^(.+)\.html(.*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.+)\\.html(.*)$', '')
const str = `https://example.com/about.html?pageback=video&jdjahdjahd`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);