$re = '/^(.+)\.html(.*)$/';
$str = 'https://example.com/about.html?pageback=video&jdjahdjahd';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;