# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.+)\.html(.*)$/$1$2/;t' <<< "https://example.com/about.html?pageback=video&jdjahdjahd"