use strict;
my $str = 'https://example.com/about.html?pageback=video&jdjahdjahd';
my $regex = qr/^(.+)\.html(.*)$/p;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";